APP ID:363994, build error with 4.2.12. Works with 4.1.6, however have different behavior than in preview app. Build error detials:ntime version: 4.2.12; AB version: 1.5.3 COMMAND: /usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/rnv/bin/index.jsconfigure -p ios -s standalone_appstore -c standalone --ci --yes --skipRnvCheck --packageManager yarn --template @appgyver/orchestra-template-standalone@4.2.12 --hooks --npxMode FAILED with ERROR: FAILED with ERROR: error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command. Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field "resolve@2.0.0-next.3" is incompatible with requested version "resolve@^1.3.2" error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. yarn install v1.22.11 [1/4] Resolving packages... [2/4] Fetching packages... info @next/swc-linux-arm64-musl@12.1.0: The platform "darwin" is incompatible with this module. info "@next/swc-linux-arm64-musl@12.1.0" is an optional dependency and failed compatibility check. Excluding it from installation. error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. Error: Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field "resolve@2.0.0-next.3" is incompatible with requested version "resolve@^1.3.2" warning @appgyver/orchestra-dolan-parser > uuid@3.1.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. warning @appgyver/orchestra-dolan-parser > @appgyver/orchestra-sdk-api > uuid@3.1.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. yarn install v1.22.11 [1/4] Resolving packages... [2/4] Fetching packages... info @next/swc-linux-arm64-musl@12.1.0: The platform "darwin" is incompatible with this module. info "@next/swc-linux-arm64-musl@12.1.0" is an optional dependency and failed compatibility check. Excluding it from installation. at makeError (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/lib/error.js:60:11) at handlePromise (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/index.js:118:26) at processTicksAndRejections (node:internal/process/task_queues:96:5) Seems like your node_modules is corrupted by other libs. ReNative will try to fix it for you [ task ] cleanNodeModules[1] [ task ] installPackageDependencies[2] packageManager:(yarn) [ error ] COMMAND: yarn FAILED with ERROR: error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command. Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field "resolve@2.0.0-next.3" is incompatible with requested version "resolve@^1.3.2" error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. yarn install v1.22.11 [1/4] Resolving packages... [2/4] Fetching packages... info @next/swc-darwin-arm64@12.1.0: The CPU architecture "x64" is incompatible with this module. info "@next/swc-darwin-arm64@12.1.0" is an optional dependency and failed compatibility check. Excluding it from installation. error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. Error: Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field "resolve@2.0.0-next.3" is incompatible with requested version "resolve@^1.3.2" warning @appgyver/orchestra-dolan-parser > uuid@3.1.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. warning @appgyver/orchestra-dolan-parser > @appgyver/orchestra-sdk-api > uuid@3.1.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. yarn install v1.22.11 [1/4] Resolving packages... [2/4] Fetching packages... info @next/swc-darwin-arm64@12.1.0: The CPU architecture "x64" is incompatible with this module. info "@next/swc-darwin-arm64@12.1.0" is an optional dependency and failed compatibility check. Excluding it from installation. at makeError (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/lib/error.js:60:11) at handlePromise (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/index.js:118:26) at processTicksAndRejections (node:internal/process/task_queues:96:5) [ error ] COMMAND: yarn FAILED with ERROR: error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command. Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field "resolve@2.0.0-next.3" is incompatible with requested version "resolve@^1.3.2" error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. yarn install v1.22.11 [1/4] Resolving packages... [2/4] Fetching packages... info @next/swc-darwin-arm64@12.1.0: The CPU architecture "x64" is incompatible with this module. info "@next/swc-darwin-arm64@12.1.0" is an optional dependency and failed compatibility check. Excluding it from installation. error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. Error: Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field "resolve@2.0.0-next.3" is incompatible with requested version "resolve@^1.3.2" warning @appgyver/orchestra-dolan-parser > uuid@3.1.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. warning @appgyver/orchestra-dolan-parser > @appgyver/orchestra-sdk-api > uuid@3.1.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. yarn install v1.22.11 [1/4] Resolving packages... [2/4] Fetching packages... info @next/swc-darwin-arm64@12.1.0: The CPU architecture "x64" is incompatible with this module. info "@next/swc-darwin-arm64@12.1.0" is an optional dependency and failed compatibility check. Excluding it from installation. at makeError (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/lib/error.js:60:11) at handlePromise (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/index.js:118:26) at processTicksAndRejections (node:internal/process/task_queues:96:5) ┌──────────────────────────────────────────────────────────────────────────────┐ │ 🚀 SUMMARY | 5/5/2022, 8:18:23 PM │ │ $ rnv configure -p ios -s standalone_appstore -c standalone --ci --yes --skipRnvCheck --packageManager yarn --template @appgyver/orchestra-template-standalone@4.2.12 --hooks --npxMode FAILED with ERROR: error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command. Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field "resolve@2.0.0-next.3" is incompatible with requested version "resolve@^1.3.2" error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. yarn install v1.22.11 [1/4] Resolving packages... [2/4] Fetching packages... info @next/swc-linux-arm64-musl@12.1.0: The platform "darwin" is incompatible with this module. info "@next/swc-linux-arm64-musl@12.1.0" is an optional dependency and failed compatibility check. Excluding it from installation. error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. Error: Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field "resolve@2.0.0-next.3" is incompatible with requested version "resolve@^1.3.2" warning @appgyver/orchestra-dolan-parser > uuid@3.1.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. warning @appgyver/orchestra-dolan-parser > @appgyver/orchestra-sdk-api > uuid@3.1.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. yarn install v1.22.11 [1/4] Resolving packages... [2/4] Fetching packages... info @next/swc-linux-arm64-musl@12.1.0: The platform "darwin" is incompatible with this module. info "@next/swc-linux-arm64-musl@12.1.0" is an optional dependency and failed compatibility check. Excluding it from installation. at makeError (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/lib/error.js:60:11) at handlePromise (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/index.js:118:26) at processTicksAndRejections (node:internal/process/task_queues:96:5) Seems like your node_modules is corrupted by other libs. ReNative will try to fix it for you │ [ error ] COMMAND: yarn FAILED with ERROR: error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command. Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field "resolve@2.0.0-next.3" is incompatible with requested version "resolve@^1.3.2" error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. yarn install v1.22.11 [1/4] Resolving packages... [2/4] Fetching packages... info @next/swc-darwin-arm64@12.1.0: The CPU architecture "x64" is incompatible with this module. info "@next/swc-darwin-arm64@12.1.0" is an optional dependency and failed compatibility check. Excluding it from installation. error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. Error: Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field "resolve@2.0.0-next.3" is incompatible with requested version "resolve@^1.3.2" warning @appgyver/orchestra-dolan-parser > uuid@3.1.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. warning @appgyver/orchestra-dolan-parser > @appgyver/orchestra-sdk-api > uuid@3.1.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details. error jest-regex-util@28.0.2: The engine "node" is incompatible with this module. Expected version "^12.13.0 || ^14.15.0 || ^16.10.0 || >=17.0.0". Got "16.9.1" error Found incompatible module. yarn install v1.22.11 [1/4] Resolving packages... [2/4] Fetching packages... info @next/swc-darwin-arm64@12.1.0: The CPU architecture "x64" is incompatible with this module. info "@next/swc-darwin-arm64@12.1.0" is an optional dependency and failed compatibility check. Excluding it from installation. at makeError (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/lib/error.js:60:11) at handlePromise (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/index.js:118:26) at processTicksAndRejections (node:internal/process/task_queues:96:5) │ │ └──────────────────────────────────────────────────────────────────────────────┘